When I launch gazebo (spawn_mira.launch) only the geometry visual (the roll pitch and yaw links) appears and there's no sign of the meshes. However, when i run RViz (urdf_visualize.launch) i can see all visuals, geometry and meshes. Also, in part 1 of the tutorial i can see the robot meshes in gazebo so it doesn't have to do with the browser or something like that.

asked 16 Feb '18, 18:06

ricardoflmota's gravatar image

ricardoflmota
0
accept rate: 0%


Hi @ricardoflmota,

We have in unit 3, after Exercise U2-1 the spawn_mira.launch file, and after executing it for the first, it's normal to not see the robot.

There is a warning below it explaining why you are not seeing the robot, even the model being there (but without visible elements).

Can you confirm you have added the inertias to the URDF model?

permanent link

answered 19 Feb '18, 20:53

marcoarruda's gravatar image

marcoarruda ♦♦
1764
accept rate: 18%

same problem i also face and even after adding inertia

permanent link

answered 21 Mar, 16:45

vishrutsingh1%40gmail.com's gravatar image

vishrutsingh...
0
accept rate: 0%

same problem i also face and even after adding inertia

permanent link

answered 21 Mar, 16:45

vishrutsingh1%40gmail.com's gravatar image

vishrutsingh...
0
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×14
×3
×1

question asked: 16 Feb '18, 18:06

question was seen: 718 times

last updated: 21 Mar, 16:45

powered by OSQA