Hi, I´m doing TF ROS 101 course and right at the beggining when I run the to first commands I should be able to drive the turtle with my keyboard, but the turtle doesn´t move. I´ve run these commands in separate shells:

roslaunch turtle_tf_3d irobot_follow_turtle.launch
roslaunch turtle_tf_3d turtle_keyboard_move.launch

I can see that turtle1/cmd_vel and turtle2/cmd_vel topics are being published via rostopic echo. But the simulation does not do anything. According to rqt_graph there aren´t any nodes subscribing to the velocity topics. alt text

The thing is, this example used to work just fine, but then I reloaded the simulation, and it stopped working. I´ve tried reloading the page, loging out and restarting the browser, but without any effect.

asked 14 Apr, 10:31

robert.pastor%40vsb.cz's gravatar image

robert.pasto...
01
accept rate: 0%

edited 14 Apr, 10:35


Hello @robert

We are suffering an error in the turtlebot robot since we changed to ROS Kinetic. 10% of times, the /cmd_vel topic dies for some strange reason. We are working hard to solve that error, and it is very likely that it will be solved on Wednesday. In the meantime, you can restore the topic by opening a different unit (or course) that doesn't use the Turtlebot and then go back to the unit you were working with turtlebot. I know it is not a good solution. we are working on solving it, so ti is only temporary.

Thanks for reporting.

Cheers

permanent link

answered 17 Apr, 17:56

marcoarruda's gravatar image

marcoarruda ♦♦
1764
accept rate: 22%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×11
×1
×1

question asked: 14 Apr, 10:31

question was seen: 324 times

last updated: 17 Apr, 17:56

powered by OSQA