Despite having followed the outlined steps, msg folder, change CMakeLists.txt and package.xml, compilation and sourcing, and verification (rosmsg list | grep Age displays Age inside my package), I still get ImportError: No module named odom_22.msg. Can anyone offer assistance?

This from odom_22.msg import Age is my import line, and I double checked to make sure the msg directory is inside my package.

asked 01 Oct, 21:31

dylmyl1029's gravatar image

dylmyl1029
0
accept rate: 0%

Never mind. I think the platform is just buggy. I restarted my computer and it works fine. Although now I have the rosdep view is empty: call 'sudo rosdep init' and 'rosdep update' when I try to run rostopic echo /age_info.

(01 Oct, 22:30) dylmyl1029

Hmmm, and now, even though I have changed nothing, it is giving me the original error again.

(01 Oct, 23:45) dylmyl1029

Got it. Had to recompile for every time my page reloaded, then I could use roslaunch. When I switched to the to terminal window to check the output with rostopic echo /age_info, I had to recompile again in this window with the roslaunch still running in the other window. Then the whole thing worked.

permanent link

answered 02 Oct, 12:43

dylmyl1029's gravatar image

dylmyl1029
0
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×3
×2

question asked: 01 Oct, 21:31

question was seen: 102 times

last updated: 02 Oct, 12:43

powered by OSQA