I'm doing exercise 3.1, but when trying to test the launch file I get the error:

[my_robot_arm_demo.launch] is neither a launch file in package [unit_3_services/] nor is [unit_3_services/] a launchfile name The traceback for the exception was written to the log file

The file is in the folder launch.

Already did source to setup.bash

Did the catkin_make and when trying to do the roslaunch it autocompletes the folder unit_3_services/

However, it doesn't autocomplete the launch file my_robot_arm_demo.launch

I also tried launching past packages but I get the same error with its launch files

U P D A T E

I tried erasing all of my projects after that created a new package and everything worked. I guess I had something wrong with a CMakeFile document or something.

asked 19 Feb, 15:54

a01337813's gravatar image

a01337813
102
accept rate: 0%

edited 08 Mar, 18:49


Hello @a01337813,

Thanks for the feedback. It's common to not have the autocomplete working at the first time you create a package. The reason why you have a folder being placed after trying to autocomplete is that ROS cli finds launch files and it suggests to launch them directly, without the package name in first place. It is also possible to launch like that:

roslaunch path/to/file.launch

Regards

permanent link

answered 08 Mar, 23:16

marcoarruda's gravatar image

marcoarruda ♦♦
1764
accept rate: 18%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×10
×6
×1
×1

question asked: 19 Feb, 15:54

question was seen: 283 times

last updated: 08 Mar, 23:16

powered by OSQA