Hello, This is my program,

the program runs perfectly fine and the robot (turtlebot) gets simulated in the "robot ignite academy" platform. The topic which I am publishing to is cmd_vel (I have altered the code here so thats not the issue) but when i run the same code in ubuntu (kinetic) after changing the topic ("cmd_vel_mux/input/teleop") because 'cmd_vel' doesnt exist in ubuntu the turtlebot does get simulated but only for 1 or 2 seconds and then it stops simulating the turtlebot. I dont know why this happens. Also, I have tried launching 'keyboard_teleop' it launches and I am able to control the robot.

please help!!!

I am using ubuntu (kinetic) with Gazebo 7

asked 05 Jul, 13:16

murtazab22's gravatar image

murtazab22
21
accept rate: 0%

edited 05 Jul, 13:17

Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×10
×5
×3
×3
×3

question asked: 05 Jul, 13:16

question was seen: 37 times

last updated: 05 Jul, 13:17

powered by OSQA