I executed the following command line

roslaunch ardrone_as action_server.launch

I got the following error

ERROR: cannot launch node of type [ardrone_as/action_server.py]: can't locate node [action_server.py] in package [ardrone_as]

What's the problem?

asked 06 Nov '17, 01:16

yelameli00831%40gmail.com's gravatar image

yelameli0083...
0
accept rate: 0%


Hi Mallikarjun,

that was a problem introduced by an upgrade that we have done on the platform.

The problem was already identified and solved.

If you run the same command again, it should work.

Thank you very much for let us know about that.

Cheers,

Ruben.

permanent link

answered 08 Nov '17, 23:23

ralves%40theconstructsim.com's gravatar image

ralves@theco... ♦♦
453
accept rate: 48%

still not working

permanent link

answered 06 May, 16:08

wenbo.zhao.111's gravatar image

wenbo.zhao.111
0
accept rate: 0%

Hi Wenbo,

I've just tried roslaunch ardrone_as action_server.launch and it worked as expected. In case it is still happening to you, could you tell us which Unit of which course you were when this error happened? And if it happens again, could you also try to reload the page?

Please let us know if the error persists.

(07 May, 06:40) ralves@theco... ♦♦

I am still getting this error in Unit 1 example 1.6 ERROR: cannot launch node of type [my_package/simple.py]: can't locate node [simple.py] in package [my_package]

alt text

permanent link

answered 31 May, 20:26

vphadnis%40amazon.com's gravatar image

vphadnis@ama...
21
accept rate: 0%

check that your python file is executable. Make it executable with chmod +x /path/to/simple.py (change the path to the real one). Next time please just post the issue as a new question, not as an answer to an existing question.

(31 May, 20:45) bayodesegun@...

thank you!

(31 May, 21:00) vphadnis@ama...
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×7

question asked: 06 Nov '17, 01:16

question was seen: 969 times

last updated: 31 May, 21:00

powered by OSQA